New tech Book by a Former Dayton Native and Friend

Windows Performance Analysis Field Guide is available on Amazon for pre-order right now.

Root your Asus HD7 Now

I couldn't find complete, straight-forward instructions for rooting my new Asus tablet, so I wrote this article.

Excellent Instructions for Using a Raspberry Pi as a Web Kiosk

I wrote this article as a result of not being able to find clear instructions on who to lock down a web kiosk I built with a Raspberry Pi computer. Learn from my Experience.

ICVerify: All your Woes Easily Solved

This is an explaination of how I cured myself of the ICVerify blues.

10 Must Know Topics for Using PowerPoint as Digital Signage

Learn from my years of usng PowerPoint as Inexpensive Digital Signage. Must Know Topics!

ICVerify “Cannot Start Program” error and Set File

Tutorial on fixing Cannot Start Program Error in ICVerify 4.

4/21/10

ICVERIFY 4.0 - user manager - admin password issues

I am posting this because I couldn't find a solution to the problem online while I was working with ICVERIFY 4.0.  It is a relatively dated program used to process credit cards.  Basically it is just a GUI on top of a few SQL databases.

In the past, if some one changed or lost the admin password to the user manager and forgot it, deleting the UserDB files from the SQL directory and reinstalling the app cured the problem.

However, yesterday, I was doing a new install on a XP machine. I choose a custom user name and password for ICVERIFY, as is an option, then completed the install.  When I went to open ICVERIFY, it thew back an error saying invalid user name password. After making sure I wasn't making a typo, I tried the default password and it didn't work.  Neither password would let me into User Manager either.

So I did as above, deleted the database files, uninstalled user manager, rebooted, then reinstalled. I tried to let it use the default login info this time.  I kept getting errors saying invalid login basically.

There was a great deal of trial and error after that.  I won't go into it.  However, my fix is the following: Uninstall ICVerify, User Manager, and the MSDE.  Go into Windows Explorer and delete the ICverify data, and the SQL data.  Use Regedit, to remove any instance of ICVERIFY, UserDB, and the SQL path.

Now, I was using a user account that was set as a local admin.  But after removing all that info, I went into my actual local admin account and reinstalled everything.  Worked fine for all users on the machine after that.

Last note, don't bother with calling their tech support line anymore.  I called today and once about 3 years ago.  Prior to today, I got a English speaking person who was well acquainted with the software and solved my problem quite quick. Today, the tech support number got me to what was obviously a 3rd party, English as a second language shop. Dude actually made it worse poking around turning off services and crap.  When he couldn't solve the problem, he gave me the "Oh you don't have a 2nd tier support contract, please buy one to continue" speech.

Anyway, I hope this helps someone out there.